Adding PHP 5.6 support to Windows XP version of WWebserver

Post Reply
arvind_dev
Posts: 1
Joined: Fri Jun 19, 2020 7:57 am

Adding PHP 5.6 support to Windows XP version of WWebserver

Post by arvind_dev » Mon Jun 22, 2020 12:59 pm

Hello,

There is a github repo containing compiled php 5.6 for Windows XP. Can you kindly use that and make a WWebserver for Windows XP which can run PHP 5.6? Because as of now only upto PHP 5.4 is supported for Windows XP? After that the min OS required is Windows Vista.

Thanks,
Arvind.

User avatar
mwiede
Site Admin
Posts: 23
Joined: Fri Oct 27, 2017 12:56 pm
Location: Germany
Contact:

Re: Adding PHP 5.6 support to Windows XP version of WWebserver

Post by mwiede » Fri Jun 26, 2020 8:11 am

arvind_dev wrote:
Mon Jun 22, 2020 12:59 pm
Hello,

There is a github repo containing compiled php 5.6 for Windows XP. Can you kindly use that and make a WWebserver for Windows XP which can run PHP 5.6? Because as of now only upto PHP 5.4 is supported for Windows XP? After that the min OS required is Windows Vista.

Thanks,
Arvind.
Ok, you mean this?
https://github.com/ProgerXP/php-5.6-xp

I will see.


Officially:

PHP 5.6 does not work for Windows XP.
PHP 5.4.45 was the last version for WinXP.

PHP 5.4 series will be the last versions to support Windows XP and Windows 2003. We will not provide binary packages for these Windows versions anymore after PHP 5.4.
https://windows.php.net/

Post Reply